Results 1 to 17 of 17

Thread: Clock Radio too fast

  1. #1
    Banned
    Join Date
    Jan 2008
    Posts
    1,101
    Thanks
    180
    Thanked 92 Times in 65 Posts
    Rep Power
    0

    Default Clock Radio too fast



    A digital clock radio gains about a minute a day.
    I thought they were locked onto the ac mains frequency of 50 Hertz, which is supposed to be very accurate and very steady.
    Am I wrong here?

    Is there something inside the unit I can adjust or place.
    It only cost me $10 bucks, but I'm worried of buying another unit and maybe it goes too fast as well.
    Perhaps my answer could be a hunt in Garage Sale for a couple of bucks.
    Would rather realign my unit for greater accuracy if someone knows how its done.
    Then I wouldn't have to turf it out and wasted my ten bucks.

    This ain't the 1st time I've had a clock radio what ran too fast.



  2. #2
    Senior Member Studio1's Avatar
    Join Date
    Jan 2008
    Location
    In the back of a 10 kW transmitter
    Posts
    1,541
    Thanks
    167
    Thanked 235 Times in 152 Posts
    Rep Power
    51

    Default

    Most clock radios are synchronised to the mains, yes.

    I have had ones before that have either lost or gained time, and I can only put it down to a faulty clock IC.
    The IC has a 50 Hz / 60 Hz selector input which operates an internal counter and I suspect this part of the circuit goes AWOL.

    Below is a link to the PDF for the TI TMS3450NL, a popular clock chip used in thousands of different designs.

    Hope this helps.


  3. #3
    Member vbthanks's Avatar
    Join Date
    Jan 2008
    Posts
    115
    Thanks
    17
    Thanked 11 Times in 11 Posts
    Rep Power
    9

    Default

    You're right - the time-base or clock is derived via a couple of components connected to the mains.
    Unfortunately there's no easy way to speed it up or slow it down inside the unit - it's probably running fast due to noise on your mains.

    Possibly the easiest way to fix this is by using a chip and crystal connected to the 'clock' input of the chip, replacing the original signal. There's a few of these chips about and most can be used with the cheap crystal from a 2 dollar watch or a TV crystal.

    vb

  4. #4
    Premium Member
    Join Date
    Jan 2008
    Location
    Shenzhen China
    Age
    49
    Posts
    1,464
    Thanks
    436
    Thanked 658 Times in 396 Posts
    Rep Power
    90

    Default

    Have seen cheap imports where the clock is set to synch at 60Hz rather than 50Hz which causes obvious problems

  5. #5
    Member GavinSV's Avatar
    Join Date
    Jan 2008
    Location
    Adelaide
    Posts
    406
    Thanks
    78
    Thanked 106 Times in 52 Posts
    Rep Power
    24

    Default

    Quote Originally Posted by moeee View Post
    A digital clock radio gains about a minute a day.
    I thought they were locked onto the ac mains frequency of 50 Hertz, which is supposed to be very accurate and very steady.
    I thought the only clocks that referanced mains AC were the old mechanical type where the digits flipped over. The mechanics are driven by an AC motor that spun a speed determined by the AC frequency.
    The newer clocks with LED/LCD displays would be driven by a crystal referenced microprocessor.

  6. #6
    Member
    Join Date
    Mar 2008
    Age
    53
    Posts
    191
    Thanks
    34
    Thanked 30 Times in 26 Posts
    Rep Power
    11

    Default

    I have seen the same problem. It was because of spikes getting into the 50Hz
    input pin. I put a small capacitor, 0.01uf I think, between the pin and ground print. The pin was fed by a resistor divider from the one of the tranformer secondary connections.

  7. #7
    Member eastlake's Avatar
    Join Date
    Feb 2008
    Location
    In the vertical interval
    Posts
    67
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    8

    Default

    Yes the mains could be part of the problem, as with many of the above posts it is most likely that there is a fault in the clock circuit. Having said that, mains frequency since the deregulation of our power industry, ie, since the breakup of the SEC has not been as tight as it should be. Both mains frequency and voltage are subject to a higher degree of variance since privatization, so the fault is most likely faulty clock timing circuitry, being helped along a bit by our poorer quality mains.
    Common sense isn't !!!

  8. #8
    Senior Member Studio1's Avatar
    Join Date
    Jan 2008
    Location
    In the back of a 10 kW transmitter
    Posts
    1,541
    Thanks
    167
    Thanked 235 Times in 152 Posts
    Rep Power
    51

    Default

    Almost every cheap (budget - made in China) type of digital clock I have seen derives its timing signal from the mains.

    As you will see in the PDF of the TMS3450NL there is a 50/60 Hz select pin on the chip.
    Even if this was in the wrong setting (ie 60 Hz when your mains is 50 Hz) it would LOSE time, not gain it.

    Noise on the mains waveform *may* cause it to run fast but I'd expect a degree of tolerance in the circuitry against such interference.

    Some of the more expensive clocks I saw in the 80s had crystal timebases in them, but that's history now as it requires more components and in these days of saving money on every part, few manufacturers would do it.

    I still have the digital clock I built back then - it uses an MM5369EYRN frequency divider that produces a 50 Hz waveform from a 3.579545 MHz crystal to drive an MM5314 dedicated clock IC.

    Technology has moved on of course and recently I built a 6 digit studio clock for my radio station - it uses 2.3" LED tiles and is driven from a PIC based circuit that has time referencing capability and also self-adjusts to maintain a high degree of accuracy. It does not rely on the mains for its reference.

  9. #9
    Member
    Join Date
    Mar 2008
    Age
    53
    Posts
    191
    Thanks
    34
    Thanked 30 Times in 26 Posts
    Rep Power
    11

    Default

    Quote Originally Posted by Studio1 View Post
    Technology has moved on of course and recently I built a 6 digit studio clock for my radio station - it uses 2.3" LED tiles and is driven from a PIC based circuit that has time referencing capability and also self-adjusts to maintain a high degree of accuracy. It does not rely on the mains for its reference.
    Cool!, Did the same sort of thing myself lately with a pic16f88. I used nixie tubes for the display.
    Last edited by rievax; 12-04-08 at 08:52 PM.

  10. #10
    Banned
    Join Date
    Jan 2008
    Posts
    1,101
    Thanks
    180
    Thanked 92 Times in 65 Posts
    Rep Power
    0

    Default

    Well I tried a .001uF capacitor across the 50 Hz input pin but it didn't help.
    I timed the unit over a 10 hour span and it lost 10 seconds.
    This turns out to be then close to 30 seconds per day.

    I was thinking if it were running too fast due to crap on the line, then it would not run 10 seconds fast in every 10 hour span because some times there may have been a period where the input was clean and sometimes extra dirty.

    I'm going to a garage sale or Laverton Market next weekend.
    Surely I'll score something for a couple of bucks.

  11. #11
    Premium Member
    Join Date
    Jan 2008
    Location
    Shenzhen China
    Age
    49
    Posts
    1,464
    Thanks
    436
    Thanked 658 Times in 396 Posts
    Rep Power
    90

    Default

    Quote Originally Posted by moeee View Post
    I timed the unit over a 10 hour span and it lost 10 seconds.
    Just wondering, what did you use to time it with?

  12. #12
    Senior Member best4less's Avatar
    Join Date
    Jan 2008
    Location
    Australia
    Posts
    7,393
    Thanks
    3,174
    Thanked 1,948 Times in 1,014 Posts
    Rep Power
    264

    Default

    Quote Originally Posted by jok11n View Post
    Just wondering, what did you use to time it with?
    LOL could be the answer
    When you do things right, people won't be sure that you have done anything at all

  13. #13
    Member
    Join Date
    Mar 2008
    Age
    53
    Posts
    191
    Thanks
    34
    Thanked 30 Times in 26 Posts
    Rep Power
    11

    Default

    Quote Originally Posted by moeee View Post
    Well I tried a .001uF capacitor across the 50 Hz input pin but it didn't help.
    I timed the unit over a 10 hour span and it lost 10 seconds.
    This turns out to be then close to 30 seconds per day.
    Hi,
    Originally your clock was gaining 1 minute per day. I still think this was most likely caused by spikes. The clock chip would be counting the spikes
    as extra cycles.
    I used a 0.01uf cap to fix a clock with the same symptom. The trick is to use
    as large a value cap as possible without causing the signal to drop too much.
    The 10 second loss might be normal depending when you tested. Mains frequency can be slightly below 50Hz during the day and higher at night.

  14. #14
    Senior Member Studio1's Avatar
    Join Date
    Jan 2008
    Location
    In the back of a 10 kW transmitter
    Posts
    1,541
    Thanks
    167
    Thanked 235 Times in 152 Posts
    Rep Power
    51

    Default

    Quote Originally Posted by rievax View Post
    Hi,
    Mains frequency can be slightly below 50Hz during the day and higher at night.
    It's not the most accurate of things to use for running a timepiece from.

  15. #15
    Senior Member gulliver's Avatar
    Join Date
    Jan 2008
    Age
    68
    Posts
    670
    Thanks
    728
    Thanked 81 Times in 63 Posts
    Rep Power
    25

    Default

    Hi,all.My clock in the Van Toyota Town ace is running fast,too.about 2 mins a month.

  16. #16
    Member Jumpingmanjim's Avatar
    Join Date
    Jan 2008
    Posts
    72
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    8

    Default

    Quote Originally Posted by gulliver View Post
    Hi,all.My clock in the Van Toyota Town ace is running fast,too.about 2 mins a month.
    Interesting, what year is it? And when did you notice this happening?

  17. #17
    Senior Member gulliver's Avatar
    Join Date
    Jan 2008
    Age
    68
    Posts
    670
    Thanks
    728
    Thanked 81 Times in 63 Posts
    Rep Power
    25

    Default

    It is a 1993/4 model and always did it. I am a sparky an travel a lot, so I always check the time with the News from the same radio station.

LinkBacks (?)

  1. 12-04-08, 07:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •