Free Giveaway !
Results 1 to 2 of 2

Thread: Ness D8 problems

  1. #1
    Junior Member
    Join Date
    Nov 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default Ness D8 problems



    I've run out of places to find an answer to a problem so hopefully someone here can help.

    I have a Ness D8 home security system which is about 11 years old. For a couple of years now and again (usually months) the panel buttons don't respond when trying to disarm. They are lit but don't respond, obviously resulting in the alarm going off. Sometimes if you keep putting the code in repeatedly is suddenly works again. It's become more frequent and certainly more frustrating to a point were we're not arming it.

    Ness had no idea what the problem was, the company I called out had no idea suggesting it could be the mother board and they'll be in touch (they havn't been yet).

    Its not the mains or battery. Its also not monitored. Not sure if its the keypad itself but every key does not work, not just the odd key. Anybody have any idea what the problem might be.



  • #2
    Member
    Join Date
    Apr 2008
    Location
    WA
    Age
    44
    Posts
    220
    Thanks
    17
    Thanked 35 Times in 27 Posts
    Rep Power
    13

    Default

    Most likely a build up of crud between the buttons and the circuit board. Common with keypads that old. If your careful you can clean them and sometimes get them working again for a few years.
    I use a special contact cleaner but a dry cloth will do the job. Don't use water/etc.

  • Members who have read this thread: 1

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •