Results 1 to 16 of 16

Thread: Which CPS version to use with MotoTRBO Firmware R01.12.17

  1. #1
    Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default Which CPS version to use with MotoTRBO Firmware R01.12.17

    Running into issue when trying to update firmware in a XPR6300. Tried CPS 13.5 and 15.5 NA. I can read and write radio so i know its not the cable. Its just when I try to update the firmware via UPDATE or RECOVER I get "Error #2898 Unable to establish a connection with the device. Please reset the device, reconnect it and try again."

    When I start the update process, the led on radio goes solid green. The radio goes into the boot loader mode and the error #2898 appears.

    Motorola XPR6300
    Current firmware R01.03.02
    Trying to update to firmware R01.12.17

    Using MotoTRBO 13.5 Build 679 NA also tried 15.5 NA same error code

    Is there a particular CPS version to use when updating gen 1 motoTRBO radios to R01.12.17 firmware?



Look Here ->
  • #2
    Senior Member

    Join Date
    Aug 2011
    Posts
    4,083
    Thanks
    609
    Thanked 2,090 Times in 1,176 Posts
    Rep Power
    1006
    Reputation
    39301

    Default

    update in steps go to 1.05-6 to 1.10-1.11 to 1.12.7 or what ever you have that is close. Do an update, read write the codeplug to be safe then update to the next firmware version.

  • #3
    Junior Member MELERIX's Avatar
    Join Date
    Aug 2017
    Location
    Chile
    Posts
    75
    Thanks
    45
    Thanked 30 Times in 16 Posts
    Rep Power
    25
    Reputation
    610

    Default

    maybe the firmware you are trying to use does not match the region of the radio, that's why it throw an error message.

  • #4
    Senior Member

    Join Date
    Aug 2011
    Posts
    4,083
    Thanks
    609
    Thanked 2,090 Times in 1,176 Posts
    Rep Power
    1006
    Reputation
    39301

    Default

    its the huge jump in the firmware. I suspect its the major changes around v12.0 CPS thats causing the issue.

  • #5
    Junior Member

    Join Date
    Jan 2013
    Posts
    167
    Thanks
    42
    Thanked 178 Times in 59 Posts
    Rep Power
    142
    Reputation
    3570

    Default

    the only cable that has allowed me to update equipment is the original Motorola PMKN4013C, only version C, I do not know why version A and B have not allowed me to update firmware R01.12.17 with CPS 14 or 15.5

  • #6
    Senior Member

    Join Date
    Aug 2011
    Posts
    4,083
    Thanks
    609
    Thanked 2,090 Times in 1,176 Posts
    Rep Power
    1006
    Reputation
    39301

    Default

    My guess is the CPS is reading the 1 wire chip in the cable.

    I have gone through the firmware library and early versions of firmware (R01.0x.xx) are few and far between. Firmware for CPS v6.x to v10.x would be useful of those trying to update older radios. Most of these units are AA region.

    Firmware files needed for the library both portables and mobiles that I would recommend would be

    v1.05.xx
    V1.07.xx
    v1.08.xx
    v1.10.xx

    the current is v1.12.17
    Last edited by lynt123; 12-06-18 at 01:11 AM.

  • #7
    Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    Quote Originally Posted by dhenar View Post
    the only cable that has allowed me to update equipment is the original Motorola PMKN4013C, only version C, I do not know why version A and B have not allowed me to update firmware R01.12.17 with CPS 14 or 15.5

    I am gonna try with a OEM PMKN4013C (Version C) and try that. My current cable is PMKN4012B. CPS 15.5 AA and CPS 14 AA. I also just tried to update a different model radio (XPR6550) with newer firmware than the 6300 and that radio also throws Error #2898. That model has a screen and I can confirm it goes into Bootloader mode on the display in addition to the solid green LED. I can read an write both radios just no firmware. I can also read and write gen 2 XPR7550 and ironically can update those no prob with the same setup. It appears to only be an issue on gen 1 firmware.

    I will post an update with my outcome with the version C cable.

  • #8
    Junior Member

    Join Date
    Jan 2013
    Posts
    167
    Thanks
    42
    Thanked 178 Times in 59 Posts
    Rep Power
    142
    Reputation
    3570

    Default

    001, excuse me,
    MERELIX asked you if the firmware you are using is from the North America region.
    Are you sure it's from the NA region?
    Confirmed, we used CPS 14.0 to update 32 radios DGP-6150 (latin america), last year, using firmware R01.12.17 for Latin America.

  • #9
    Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    The firmware file is R01.12.17 - 130203

    Is there a read me file in it to determine the region? The CPS 14 and CPS 15.5 I am using are confirmed AA.

  • #10
    Junior Member

    Join Date
    Jan 2013
    Posts
    167
    Thanks
    42
    Thanked 178 Times in 59 Posts
    Rep Power
    142
    Reputation
    3570

    Default

    the firmware I use to update says, "LA_MOTOTRBO_R011217_130203_Portable". "LA" is from Latin America.
    Today in the morning I updated a mobile radio DGM-6100 from version R01.12.13 to version R01.12.17, it was not far from the latest version.
    I used win 7 32 Pro and Mototrbo CPS 15.5

  • #11
    Junior Member
    Join Date
    Oct 2012
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    I just tried the PMKN4013 version C and still getting the same error message. Its reads and writes like the other cable just not able to update the firmware. The only this left to troubleshoot is the actual R01.12.17 firmware file. It may not be a AA region. Does anyone have AA (US) edition of the R01.12.17 firmware I could try?

  • #12
    Junior Member

    Join Date
    Jan 2013
    Posts
    167
    Thanks
    42
    Thanked 178 Times in 59 Posts
    Rep Power
    142
    Reputation
    3570

    Default

    as Lynt told you, try with other firmwares.
    Search in "Firmware Library", page 22, post 433.
    NA Firmware R01.07.04 portable

  • #13
    Senior Member

    Join Date
    Aug 2011
    Posts
    4,083
    Thanks
    609
    Thanked 2,090 Times in 1,176 Posts
    Rep Power
    1006
    Reputation
    39301

    Default

    The library needs AA firmware as mentioned in post #6

  • #14
    Junior Member

    Join Date
    Jan 2013
    Posts
    167
    Thanks
    42
    Thanked 178 Times in 59 Posts
    Rep Power
    142
    Reputation
    3570

    Default

    AZ:Asia/Australia
    LA:Latin America
    AA;North America
    MD:Europe/Middle East/Africa

  • #15
    Premium Member
    Join Date
    Dec 2011
    Posts
    23
    Thanks
    35
    Thanked 61 Times in 11 Posts
    Rep Power
    95
    Reputation
    775

    Default

    here is r11217 na portable firmware hope it helps
    Last edited by r.will91; 17-06-18 at 12:57 PM.

  • #16
    Junior Member MELERIX's Avatar
    Join Date
    Aug 2017
    Location
    Chile
    Posts
    75
    Thanks
    45
    Thanked 30 Times in 16 Posts
    Rep Power
    25
    Reputation
    610

    Default

    Quote Originally Posted by r.will91 View Post
    here is r11217 na portable firmware hope it helps
    please remember to post firmwares in the right thread, here:

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •