Results 1 to 7 of 7

Thread: Kia Sorento MY13 SAT NAV Stuck on "Agree" screen.

  1. #1
    Junior Member
    Join Date
    Jan 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default Kia Sorento MY13 SAT NAV Stuck on "Agree" screen.

    Model: Kia Sorento SLi MY13 SAT NAV
    Location: Gold Coast Australia.
    My Sat Nav stopped working and is stuck on the "Agree" screen.

    All other functions (Radio, Bluetooth, Media player) are working fine.
    When I start the vehicle I get an error saying "Load Language failed"

    I have seen the Kia Dealership at Southport, QLD and they told me that I would have to book in for an update and that would cost $250 and they referred me to Kia Australia.
    I called Kia Australia and they referred me back to the dealership, and said they should of had a look.

    I would like to know If anyone on here could help me in getting this up and running.
    I specifically paid for this feature when I purchased the vehicle, so really pissed off about it.

    Thanks in advance
    Mike.



Look Here ->
  • #2
    Senior Member
    fandtm666's Avatar
    Join Date
    Jan 2008
    Posts
    5,461
    Thanks
    231
    Thanked 961 Times in 448 Posts
    Rep Power
    1163
    Reputation
    39867

    Default

    try doing a system rest

  • #3
    Banned

    Join Date
    Jan 2017
    Location
    still above ground level
    Posts
    1,779
    Thanks
    5,562
    Thanked 1,962 Times in 714 Posts
    Rep Power
    0
    Reputation
    35617

    Default

    get a bigger stick and start waving it in their face .

  • #4
    Junior Member
    Join Date
    Jan 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    Quote Originally Posted by fandtm666 View Post
    try doing a system rest
    Yes I tried that by pressing a small tiny button on the top left of the unit, but that did not work.

  • #5
    Senior Member
    fandtm666's Avatar
    Join Date
    Jan 2008
    Posts
    5,461
    Thanks
    231
    Thanked 961 Times in 448 Posts
    Rep Power
    1163
    Reputation
    39867

    Default





    Last edited by fandtm666; 14-02-19 at 06:25 PM.

  • #6
    Junior Member
    Join Date
    Jan 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    I shall give this a go.
    Thanks for all the info. Much appreciated.

  • #7
    Junior Member
    Join Date
    Jul 2011
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default

    Did u end up getting it fixed
    ,Iím in the some situation now

  • Tags for this Thread

    Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •