Results 1 to 4 of 4

Thread: TM9100 strange LCD appearance after power off

  1. #1
    Senior Member
    Wi-Fi's Avatar
    Join Date
    Aug 2012
    Posts
    794
    Thanks
    227
    Thanked 171 Times in 109 Posts
    Rep Power
    190
    Reputation
    3856

    Default TM9100 strange LCD appearance after power off

    Here is how it looks like immediately after power off and much much later:









    And similar situation lasts a very long time. And it takes several hours (a whole night is enough) for the LCD to clear completely.

    Is it normal appearance?

    P.S.
    Radio is BNIB.

    P.P.S.
    The control head is TMAC41-000, HW version 0201. Most current firmware is loaded.



Look Here ->
  • #2
    Senior Member

    Join Date
    Aug 2011
    Posts
    4,502
    Thanks
    660
    Thanked 2,341 Times in 1,311 Posts
    Rep Power
    1135
    Reputation
    44321

    Default

    That type of issue is caused by a cap discharging into the display. it looks ugly but wont hurt the radio.

  • #3
    Junior Member The Butcher's Avatar
    Join Date
    Apr 2011
    Posts
    238
    Thanks
    40
    Thanked 46 Times in 38 Posts
    Rep Power
    124
    Reputation
    745

    Default

    mmm more like a buggered LCD. If it was a cap (which it is not) it would go away over time (RC time constant of discharge).
    Last edited by The Butcher; 27-05-19 at 11:55 AM.

  • #4
    Administrator
    mtv's Avatar
    Join Date
    Apr 2008
    Posts
    17,793
    Thanks
    5,195
    Thanked 11,526 Times in 5,679 Posts
    Rep Power
    4056
    Reputation
    166211

    Default

    I'd agree it's a display issue itself.

    Often just a poor/intermittent connection with the LCD.

    Being brand new, I'd recommend returning it for a replacement as it's faulty.

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •