Results 1 to 12 of 12

Thread: Brivis ducted heating issues.

  1. #1
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default Brivis ducted heating issues.

    Worst bloody time of year and our heater looks to have died, being an older model lots of parts are obsolete (1996). Igniter ,fan etc works but keep getting the rest light flashing and pressing the button doesnt fix it.
    I have tried the rest button on the circuit board and then i get the ALM diagnostic LED flashing and even google doesnt tell me what that means, i have cleaned out the jets as it appears to be a gas issue as i can hear the solenoid click but no gas is released. Cant find anyone that looks like a thermocouple or thermistor, i'm thinking the gas control valve is dead and they are no longer available.



Look Here ->
  • #2
    Premium Member
    ol' boy's Avatar
    Join Date
    Jan 2008
    Posts
    16,700
    Thanks
    7,614
    Thanked 9,339 Times in 4,746 Posts
    Rep Power
    3936
    Reputation
    161852

    Default

    Got a model number?
    If u want to go on an expedition get a Land Rover, if u want to come home from an expedition get a Landcruiser!

  • #3
    Premium Member
    hoe's Avatar
    Join Date
    Jan 2008
    Location
    -30.7719955,121.495211
    Age
    55
    Posts
    5,444
    Thanks
    222
    Thanked 3,448 Times in 1,502 Posts
    Rep Power
    1275
    Reputation
    47568

    Default



    that it ?



    Finally got FTTN, 710m line length....

  • #4
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default

    Quote Originally Posted by hoe View Post


    that it ?
    No VR8605, they only come up on Russian sites for some reason.

    Sent from my K10000 using Tapatalk

  • #5
    Premium Member

    Join Date
    Feb 2008
    Posts
    3,121
    Thanks
    1,612
    Thanked 1,701 Times in 837 Posts
    Rep Power
    733
    Reputation
    24408

    Default

    I feel your pain after stuffing around with mine for two years
    Model type, internal or external, thermo switched?. Number one check your solenoid switch
    Guarantee it is your board, on my second one, changed thermo switch, thermo coupler etc
    Depending on your model they had a defective board on them 1996+/_ same age as mine
    A guy does reco boards in Frankston, another mob in Moorabbin
    Mine would work but had to keep manually switching it on till it fired
    Take a picture of the front, all the best
    There is a fine line between "Hobby" and "Madness"

  • The Following User Says Thank You to allover For This Useful Post:

    loanrangiel (22-08-19)

  • #6
    Premium Member
    hoe's Avatar
    Join Date
    Jan 2008
    Location
    -30.7719955,121.495211
    Age
    55
    Posts
    5,444
    Thanks
    222
    Thanked 3,448 Times in 1,502 Posts
    Rep Power
    1275
    Reputation
    47568

    Default



    Sent from my VOG-L09 using Tapatalk



    Finally got FTTN, 710m line length....

  • #7
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default

    Quote Originally Posted by hoe View Post


    Sent from my VOG-L09 using Tapatalk
    Thats similar but missing a solenoid, these brivis heaters are very common yet can hardly find any info or troubleshooting of them online.

  • #8
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default

    Quote Originally Posted by allover View Post
    I feel your pain after stuffing around with mine for two years
    Model type, internal or external, thermo switched?. Number one check your solenoid switch
    Guarantee it is your board, on my second one, changed thermo switch, thermo coupler etc
    Depending on your model they had a defective board on them 1996+/_ same age as mine
    A guy does reco boards in Frankston, another mob in Moorabbin
    Mine would work but had to keep manually switching it on till it fired
    Take a picture of the front, all the best
    I have read that the boards give issues but its hard to test without getting someone to look at it, i'll take a pic and post it.
    Last edited by loanrangiel; 22-08-19 at 05:50 PM.

  • #9
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default

    Bloody typical, i took the CB covers off to take the pic and came inside and turned it on then went out to check and it lit after i hit the reset button. Could this be a faulty thermo switch or thermocouple ? i cant find where to even look for them on this model - Brivis Buffalo HE5.

  • #10
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,526
    Thanks
    353
    Thanked 517 Times in 356 Posts
    Rep Power
    363
    Reputation
    7138

    Default

    Set the timer thursday night and it started and ran for the 3hr set time friday morning but every other time we turn it on it runs for about 15mins before the reset light flashes ?

  • #11
    Premium Member

    Join Date
    Feb 2008
    Posts
    3,121
    Thanks
    1,612
    Thanked 1,701 Times in 837 Posts
    Rep Power
    733
    Reputation
    24408

    Default

    Don't stuff around like i did, just change the board then concentrate on the other problems if they persist
    There is a fine line between "Hobby" and "Madness"

  • The Following User Says Thank You to allover For This Useful Post:

    loanrangiel (27-08-19)

  • #12
    Premium Member

    Join Date
    Feb 2008
    Posts
    3,121
    Thanks
    1,612
    Thanked 1,701 Times in 837 Posts
    Rep Power
    733
    Reputation
    24408

    Default

    And another link, tell me when to stop
    There is a fine line between "Hobby" and "Madness"

  • The Following User Says Thank You to allover For This Useful Post:

    loanrangiel (27-08-19)

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •