Results 1 to 2 of 2

Thread: igo primo new map problems

  1. #1
    Junior Member
    Join Date
    Nov 2019
    Location
    East Maitland
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Reputation
    10

    Default igo primo new map problems

    Hi every body I have a igo Primo in my nissan patrol (the original one turned its toes up)

    I cant get the update all sites I hav tried do not have an referance to igo primo.

    Any info would be great.

    Regards Rob Poynter



Look Here ->
  • #2
    Premium Member

    Join Date
    Jan 2008
    Posts
    4,147
    Thanks
    5,445
    Thanked 3,999 Times in 1,689 Posts
    Rep Power
    1210
    Reputation
    46301

    Default

    Welcome to the Austech forums, Rob.

    I hope that you have a long and fruitful association with us.

    This section, Introduce Yourself, is where new members tell us a little about themselves, their occupation, interests and hobbies, location etc.

    There are many sections of the forum, each dedicated to particular subject matter.

    As your question is about GPS updates, the appropriate section for your post is the , a little further down the Austech homepage, where other GPS users will see it and be able to help.

    You might find that a similar query has been made before. You can search the forum by using the SEARCH button located at upper right of the webpage. I recommend that you use the facility.

    Enjoy your stay and please contribute to the threads where you are able to.

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •