Results 1 to 6 of 6

Thread: Samsung Galaxy tablet wont power on.

  1. #1
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,543
    Thanks
    356
    Thanked 521 Times in 360 Posts
    Rep Power
    368
    Reputation
    7218

    Default Samsung Galaxy tablet wont power on.

    I have a friends galaxy tablet kids version that wouldn't power on, they bought a new battery as its about 7 years old and asked to fit which i have but it still wont power up.
    No visible damage to it and not sure what else to check.



Look Here ->
  • #2
    Premium Member
    hoe's Avatar
    Join Date
    Jan 2008
    Location
    -30.7719955,121.495211
    Age
    56
    Posts
    5,476
    Thanks
    225
    Thanked 3,469 Times in 1,510 Posts
    Rep Power
    1287
    Reputation
    47988

    Default

    what happens if you plug a charger in ?



    Finally got FTTN, 710m line length....

  • #3
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,543
    Thanks
    356
    Thanked 521 Times in 360 Posts
    Rep Power
    368
    Reputation
    7218

    Default

    Quote Originally Posted by hoe View Post
    what happens if you plug a charger in ?
    Nada although i suspect the charge port may be knackered, did some googling and it appears this model is known for powering on issues. Tried all the suggestions of button combinations and unplugging battery etc to no avail..

  • #4
    Premium Member
    hoe's Avatar
    Join Date
    Jan 2008
    Location
    -30.7719955,121.495211
    Age
    56
    Posts
    5,476
    Thanks
    225
    Thanked 3,469 Times in 1,510 Posts
    Rep Power
    1287
    Reputation
    47988

    Default

    Check for bent/shorted pins in the charge socket.

    Happens with that stupid one way socket....

    Sent from my SM-T355Y using Tapatalk



    Finally got FTTN, 710m line length....

  • #5
    Junior Member Bobby Slogger's Avatar
    Join Date
    Jan 2008
    Posts
    206
    Thanks
    16
    Thanked 44 Times in 29 Posts
    Rep Power
    162
    Reputation
    550

    Default

    I might be getting models mixed up but it could be the main board. I had one that wouldn't power up - tried new batteries etc. Got a second unit that'd a damaged screen - swapped the boards and the unit worked (with what I thought was a faulty battery). I think it might have been a faulty power chip but not sure. Unit is now dead after abuse,

  • #6
    Senior Member

    Join Date
    Jun 2008
    Location
    Melbourne, NE.
    Age
    51
    Posts
    2,543
    Thanks
    356
    Thanked 521 Times in 360 Posts
    Rep Power
    368
    Reputation
    7218

    Default

    Its possible, haven't had another look at it and the the owner isnt too fussed as it is an old model.

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •