Results 1 to 9 of 9

Thread: Weird issue with Guest Network

  1. #1
    Crazy Diamond
    Tiny's Avatar
    Join Date
    Dec 2010
    Location
    Tasmania
    Age
    62
    Posts
    6,272
    Thanks
    10,734
    Thanked 5,267 Times in 2,590 Posts
    Rep Power
    2056
    Reputation
    85677

    Default Weird issue with Guest Network

    As per title, experiencing a weird issue with Guest Network on my Linksys WRT 1900, it wont let guests , both with W10, sign in even though the Guest network is enabled. All devices including mine just get the following message. I have tried resetting, turn network on & off, different browser. No joy. I think the last phrase in the message tells the story, W10 has decided that the port being used is not safe.
    Anyone know how to solve this. I had to let a friend use my full network to access the internet, so that's a lot less safe than the guest network, right?


    Cheers, Tiny
    "You can lead a person to knowledge, but you can't make them think? If you're not part of the solution, you're part of the problem.
    The information is out there; you just have to let it in."



Look Here ->
  • #2
    Premium Member
    hoe's Avatar
    Join Date
    Jan 2008
    Location
    76 totters lane
    Age
    58
    Posts
    5,894
    Thanks
    244
    Thanked 4,037 Times in 1,726 Posts
    Rep Power
    1552
    Reputation
    59348

    Default

    try putting it on a different subnet....
    https://www.speedtest.net/result/d/7...193b4402e8.png

    FTTN, 710m line length, bit faster now with draytek modem....

  • #3
    Crazy Diamond
    Tiny's Avatar
    Join Date
    Dec 2010
    Location
    Tasmania
    Age
    62
    Posts
    6,272
    Thanks
    10,734
    Thanked 5,267 Times in 2,590 Posts
    Rep Power
    2056
    Reputation
    85677

    Default

    Quote Originally Posted by hoe View Post
    try putting it on a different subnet....
    Putting what on a different subnet?
    Treat me like I don't know anything, but you already knew that, right!

    BTW: android phone & iPhone can connect to the Guest network, no issue.
    Last edited by Tiny; 18-10-21 at 08:33 PM.
    Cheers, Tiny
    "You can lead a person to knowledge, but you can't make them think? If you're not part of the solution, you're part of the problem.
    The information is out there; you just have to let it in."

  • #4
    Premium Member
    wotnot's Avatar
    Join Date
    Nov 2019
    Posts
    1,799
    Thanks
    759
    Thanked 1,632 Times in 862 Posts
    Rep Power
    738
    Reputation
    32650

    Default

    That's a browser error -- try M$ Edge browser as an experiment.

  • #5
    Senior Member

    Join Date
    Dec 2011
    Location
    Tasmania
    Posts
    792
    Thanks
    1,236
    Thanked 843 Times in 368 Posts
    Rep Power
    469
    Reputation
    16061

    Default

    ERR_UNSAFE_PORT

    After the 192.168.x.y is there a : followed by a number? Your browser may be trying to stop itself from redirecting to a port other than 443 or port 80?

  • The Following User Says Thank You to shred For This Useful Post:

    wotnot (18-10-21)

  • #6
    Premium Member
    wotnot's Avatar
    Join Date
    Nov 2019
    Posts
    1,799
    Thanks
    759
    Thanked 1,632 Times in 862 Posts
    Rep Power
    738
    Reputation
    32650

    Default

    Quote Originally Posted by shred View Post
    ERR_UNSAFE_PORT

    After the 192.168.x.y is there a : followed by a number? Your browser may be trying to stop itself from redirecting to a port other than 443 or port 80?
    I think it's happening before that (redirection) ; it's hoisting the error on the secure port connection from the get go...but I don't know about Opera...it's closed source --- I mean, I know it's based on Chrome, but it seems the Opera devs have removed user configuration options here --- in Chrome (FF and others), these config params are exposed, but not in Opera it seems (and it's likely getting paranoid about a URL starting with http:// that ends up on a port other than :80 ) Bit hard to say seeing as OP has scribbled over 'useless' info...as in, that data discloses nothing of interest, caveat those trying to look at it to figure out what's going on =) Not that it matters...not being able to see the entire error message already has one's hand tied behind back...but not to worry, try another browser...(nb: and the only reason I leap to Edge, is win10 is more likely to get along with it, but known workarounds for this issue exist for Chrome/FF)

    FWIW....I take it this is a wifi 'guest' account shizzle with the router? I can attest to the fact that I no longer found a use for that functionality, after wireless routers routinely appeared sporting dual band capabilities --- to example the setup here, 2.4g/5g wifi radios in the router, so 2 SSIDs of frypan/kettle respectively, each with a different passphrase -- all the household wifi appliances connect to the 5g radio (kettle), and the 2.4g radio (frypan) has the simplistic passphrase of 12345678 and if someone turns up here who wants to use the wifi, I point them to this setup, and change the passphrase when they leave. I think it's easier B^)

  • #7
    Crazy Diamond
    Tiny's Avatar
    Join Date
    Dec 2010
    Location
    Tasmania
    Age
    62
    Posts
    6,272
    Thanks
    10,734
    Thanked 5,267 Times in 2,590 Posts
    Rep Power
    2056
    Reputation
    85677

    Default

    Ok, then. yes it's a wireless guest network, it is dual band & has 2.4 & 5Ghz for my network & Guest network.
    Sorry for scribbling out the address info, but i thought it unwise to put the address of my network on the internet
    here's the whole message on Edge browser.


    and this popped up as well with Edge but not with Opera.

    Cheers, Tiny
    "You can lead a person to knowledge, but you can't make them think? If you're not part of the solution, you're part of the problem.
    The information is out there; you just have to let it in."

  • #8
    Premium Member
    wotnot's Avatar
    Join Date
    Nov 2019
    Posts
    1,799
    Thanks
    759
    Thanked 1,632 Times in 862 Posts
    Rep Power
    738
    Reputation
    32650

    Default

    Ahh, windows...it's like an open wound with 3 or 4 bandaids stuck ontop, while the infection continues unabated.

    Thanks Tiny -- nothing wrong with being paranoid, but so you know, search google for 'private network ip range' and you'll understand seeing 192.168.xxx.xxx means nothing ; literally millions of machine will be using the same IP ...nothing disclosed =)

    However, we now know it's Lenovo computer, still replete with all the lenovo value add bloatware called vantage still installed...sigh....so you're wrestling with that, browsers and win10 all at the same time...fun fun, I don't envy folks in this spot.

    First thing is, the router itself -- has facility to do automatic updates, has a woeful (and recent) bad security history --> [I'd be turning auto updates OFF, and checking firmware version]

    Second thing that stands out, is the redirect to --> ...that makes absolutely no sense to me (I know what it says, I just don't understand why)...so I searched around that trinket.



    So...you have to vet the windows machines to ensure that virus isn't involved, then you'd need do this ...and I still don't know where the redirect is coming from (if you did all this and it still displays the same error, one needs suspect the router firmware is doing it).

    Quick, safest solution? Install linux =)

    Quick solution -- forget about the guest account setup, and setup your router something like I describe above, and let the windows machines directly connect to wifi router (there is no appreciable benefit or security in using the guest network login)

  • The Following User Says Thank You to wotnot For This Useful Post:

    Tiny (19-10-21)

  • #9
    Crazy Diamond
    Tiny's Avatar
    Join Date
    Dec 2010
    Location
    Tasmania
    Age
    62
    Posts
    6,272
    Thanks
    10,734
    Thanked 5,267 Times in 2,590 Posts
    Rep Power
    2056
    Reputation
    85677

    Default

    Thanks wotnot, it was number 2 in the last link you have above at

    Makes sense that it had to be a Windows setting, as the other laptop had never been here before & my laptop had never used Guest network before. So could not be a virus or malware from the guests laptop as it never got connected untill an hour later when I let her use my Main wifi network & a Virus & malware scan of my laptop was clean.
    Also all other connections over the last few years thru the Guest network were from Phones (Android & iPhone) or iPads.
    at least I know how to simply fix it now. Thanks for humouring me & pointing me in the right direction.

    Have you ever wondered how Windows figures out if you have a stable internet connection? It takes a few seconds, usually for Windows, to tell that the internet is not working if there is an issue. So what happens in the background is that Windows tries to connect to msftconnecttest.com and download a file connecttest.txt. If the download fails, it figures there is an issue with the internet. That said, at times, you may receive a lot of redirect error for the msftconnecttest. In this post, we will show how you can remove the msftconnecttest redirect error.


    How to remove msftconnecttest redirect error
    The redirection happens because Windows is trying to download that file but is either getting blocked and hence it is repeating in the loop. It majorly happens for two reasons. First is when you have an Antivirus or VPN blocking the URL(msftconnecttest.com and ipv6.msftconnecttest.com ), and second is when you connect to a WIFI, which is behind a login page. When that happens, you should notice that the network icon now displays a glob icon, which signifies that there is no internet.


    Here are we are offering multiple solutions, and you can choose any of them.
    Disable WiFi/VPN or configure Antivirus
    Disable Microsoft Internet Connection Test using Registry Editor
    Use Group Policy to disable Microsoft Internet Connection Test
    Change Internet connection test server
    The second and third method works if you are not part of a domain or restricted by IT policies. Only IT admin can make the changes if thatís the case. IT admins can also use the third method to resolve the issue in a better way.


    1] Disable WiFi/VPN or whitelist Microsoft msftconnecttest URLs
    These are common errors we mentioned, and it would be best if you can disable WiFi or VPN to check if the error is resolved. If yes, then itís because of them, and you need to figure out how to add the URLs msftconnecttest.com and ipv6.msftconnecttest.com to Whitelist, so it is not blocked either by the VPN or Antivirus. If its the WiFi Login page that is causing the problem, then you should either login or turn off the WiFi.


    2] Disable Microsoft Internet Connection Test using Registry Editor
    remove msftconnecttest redirect error via Registry



    The easy way out of the problem is to disable the internet connection test. It can be done via the Registry Editor.


    Open the Registry Editor by typing Regedit in the Run prompt followed by pressing the Enter key
    Navigate to the following keyHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\NlaSvc\Parameters\Internet


    Open the EnableActiveProbing DWORD in edit mode by double-clicking on it
    Change the Value data from 1 to 0.
    Exit the Registry editor.
    Post this, Windows will not check for Internet availability, and that should eventually stop the msftconnecttest.com redirect error. Windows 10 Home users should use this method as Group Policy Editor is not available for them.
    Last edited by Tiny; 19-10-21 at 06:13 PM.
    Cheers, Tiny
    "You can lead a person to knowledge, but you can't make them think? If you're not part of the solution, you're part of the problem.
    The information is out there; you just have to let it in."

  • The Following User Says Thank You to Tiny For This Useful Post:

    wotnot (19-10-21)

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •