Results 1 to 9 of 9

Thread: Garmin Dezl 580 LMT - D : will not power up - corrupted firmware / boot software?

  1. #1
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default Garmin Dezl 580 LMT - D : will not power up - corrupted firmware / boot software?

    I have acquired a Garmin Dezl 580LMT-D sat nav.

    I plugged the unit into a real Garmin automotive charger. After a few minutes the unit automatically booted up (flat battery?) and appeared to work 100%. I was able to log on to my wi-fi connection and a maps/software update would have taken over 3 hours so I decided to do it later.

    With the sat nav appearing to work 100%, I powered down BUT the unit would not boot up on pressing the on/off button. I held in the on/off button to do a soft reset and the unit booted up and was again working OK..until I powered down again. I had to keep holding in the on/off key or leaving the unit on charge and it eventually booted.

    I decide to follow the various You Tube reset guides and do a full reset...and also erased all user data. The unit again worked BUT would still not boot up using the on/off key.

    I attempted another full reset BUT now the unit only powers up at some random time after connecting the Garmin charger and then freezes on the "Warning Allow" screen. When I hold in the on/off key I get the "Turn Off Device / Cancel / Off" message BUT when I press Off the screen remains frozen and nothing happens. The unit is also NOT recognised when I try to connect to a pc running Garmin Express.

    I have opened up the unit and disconnected the battery for 30 minutes BUT when the battery is reconnected the unit still does not boot up when the on/off key is pressed. When a charger is connected the unit will again boot after some time but again freezes on the "Warning Allow" screen.

    Any ideas? I was thinking that the boot software / firmware is corrupted? Maybe the corruption was only "minor" to begin with (so the unit worked but would not boot up after powering down) but the corruption has got worse after doing multiple resets so the unit now freezes on the "Warning Allow" screen . Maybe I need to reinstall the boot software/firmware using an SD card is this is possible?

    Thanks



Look Here ->
  • #2
    Crazy Diamond
    Tiny's Avatar
    Join Date
    Dec 2010
    Location
    Tasmania
    Age
    62
    Posts
    6,312
    Thanks
    10,827
    Thanked 5,330 Times in 2,616 Posts
    Rep Power
    2092
    Reputation
    86937

    Default

    Did you try all the suggestions here >
    Cheers, Tiny
    "You can lead a person to knowledge, but you can't make them think? If you're not part of the solution, you're part of the problem.
    The information is out there; you just have to let it in."

  • The Following User Says Thank You to Tiny For This Useful Post:

    jmwtzl (19-07-22)

  • #3
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default

    Tiny - thanks for the excellent suggestion. I will check out all the options. I was aware of the GPS Power forum but I don't think I would have ever located the relevant pages without your help!! I'm mainly a comms enthusiast and use Austech Comms forum so I will need to build up my Garmin GPS knowledge.

  • #4
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default

    I have logged onto GPS Power but I am not receiving an Activation email. I have tried numerous times and different emails and checked the spam. It says to send a PM message to the Forum Admin if no Activation Email is sent but I cannot find the PM for Forum Admin

  • #5
    Premium Member
    wotnot's Avatar
    Join Date
    Nov 2019
    Location
    Scenic Rim, SE Qld
    Posts
    2,545
    Thanks
    1,223
    Thanked 2,299 Times in 1,207 Posts
    Rep Power
    1039
    Reputation
    45990

    Default

    Quote Originally Posted by jmwtzl View Post
    I have logged onto GPS Power but I am not receiving an Activation email. I have tried numerous times and different emails and checked the spam. It says to send a PM message to the Forum Admin if no Activation Email is sent but I cannot find the PM for Forum Admin


  • #6
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default

    I can log in OK...but not activate.

    It says for activation issues contact forum admin. I've searched on the GPS Power forum and found an admin name and sent a message.

    Maybe I will join Facebook but that is for logging problems not activation issues??

  • #7
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default

    I have now managed to obtain the GarminCure3 MSM enabler software and RMPrepUSB formatting tool

    Does anybody have Garmin Dezl580 Firmware. I've search the various forum and can only find F/W for the Dezl560 not the 580.

    There is also some universal "QuickCure3" F/W which can be used instead of the actual model specific F/W...but I don't understand how to rename the file??

    Also, I can't figure out how to put the 580 into Pre-Boot mode. I've tried all the various options for other models.

    At the moment, my Dezl580 sort of boots randomly but freezes. The Garmin logo screen comes up with "loading" maybe 5 -15 minutes after pressing the on/off switch and then the "Warning Allow" screen but it freezes at this stage and nothing happening when Allow is pressed.

    Maybe there is some way to install GarminCure3 via an SD card? I presume the usual way to install GarminCure3 is by putting the unit into Pre-Boot mode but I've not been able to enable Pre-Boot mode.

  • #8
    Member
    Surething's Avatar
    Join Date
    Dec 2012
    Posts
    295
    Thanks
    100
    Thanked 249 Times in 144 Posts
    Rep Power
    203
    Reputation
    3720

    Default

    Quote Originally Posted by jmwtzl View Post
    I have now managed to obtain the GarminCure3 MSM enabler software and RMPrepUSB formatting tool

    Does anybody have Garmin Dezl580 Firmware. I've search the various forum and can only find F/W for the Dezl560 not the 580.
    This is all i can find for dezl 580: . You may know already that UAT means "User Acceptance Testing" so basically it's still a beta version. Usually these UAT firmware versions aren't made freely available by Garmin to retail consumers however it seems by the naming (version 1.01) that there's an implied version 1.00 so maybe it was replaced because of bugs (who knows? Garmin is Garmin after all ...). If your device is running V1.00 and it's that GCD file causing the problem and assuming you still have Mass Storage Mode or Media Transfer Protocol available (ie it can bee seen by Windows File Explorer on PC) then simply connecting it to GarminExpress should update it to V1.01 without problems. Otherwise you can use WebUpdater and follow the directions on the 'view source' page by going to and then pressing Ctrl+U keys together on your keyboard. This is what you'll see at the top:
    Code:
    1) To download the region file used by WebUpdater, copy and paste this link into your browser
       on computer #1:
    
       https://download.garmin.com/software/UAT-2826_101.gcd
    
    2) Bring UAT-2826_101.gcd to computer #2 where your device is attached.
    
    3a) Then you can drag-and-drop UAT-2826_101.gcd onto the WebUpdater icon on your desktop.
    
    3b) Or you can invoke WebUpdater at the command line, passing in the region file as a parameter:
    
       C:\>WebUpdater.exe c:\path\to\UAT-2826_101.gcd
    There is also some universal "QuickCure3" F/W which can be used instead of the actual model specific F/W...but I don't understand how to rename the file??
    Before using QuickCure3, the 'safe-naming' protocol of <HWID>01000<SWV>.RGN is used. So for dezl 580 that's 282601000101.rgn. However don't do anything with that, unless later it's needed as shown by other suggested fixes not working. Loading cure fw when it's not necessary is worse than pointless and it's only used if the device is bricked to the point that it can't be seen by Windows File Explorer.

    Also, I can't figure out how to put the 580 into Pre-Boot mode. I've tried all the various options for other models.
    Modern Garmin auto devices are purposefully made notoriously difficult for normal users to manipulate and gaining preboot mode is the usual way to load 'unofficial' firmware. Seeing as your device does partially boot it might be getting far enough into the boot process to read firmware BIN files from a media card. It might be sufficient to load V1.01 as BINs using that method but i'd recommend against attempting using SD method to load cured fw at this point pending further investigation (see below).

    At the moment, my Dezl580 sort of boots randomly but freezes. The Garmin logo screen comes up with "loading" maybe 5 -15 minutes after pressing the on/off switch and then the "Warning Allow" screen but it freezes at this stage and nothing happening when Allow is pressed.
    That can be a symptom of an update file that is trying to load on boot (brief explanation: during the boot cycle, the device looks for software update files both on the device and in a Garmin folder on any inserted microSD and attempts to run them - hence 'Loading' showing on the screen). If you have a media card inserted remove it and then try to boot it.

    It can also be an quite uncommon symptom of a hardware fault but let's eliminate the more likely problem of a faulty file first. Although it's rare a flash chip failure is likely fatal.

    Maybe there is some way to install GarminCure3 via an SD card? I presume the usual way to install GarminCure3 is by putting the unit into Pre-Boot mode but I've not been able to enable Pre-Boot mode.
    If you want to do what i've suggested above with the BIN files but don't know what i mean let me know what version of fw is loaded presently and i'll help you further. Look at the GarminDevice.xml in the Garmin folder of the device:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <Device xmlns="http://www.garmin.com/xmlschemas/GarminDevice/v2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.garmin.com/xmlschemas/GarminDevice/v2 http://www.garmin.com/xmlschemas/GarminDevicev2.xsd">
    <Model>
    
    <PartNumber>006-B2826-00</PartNumber>
    
    <SoftwareVersion>xxx</SoftwareVersion>
    It's the 3 numerals represented by 'xxx' in bold red above that i need.
    Last edited by Surething; 30-07-22 at 11:31 AM.

  • The Following 3 Users Say Thank You to Surething For This Useful Post:

    Jma (31-07-22),jmwtzl (15-08-22),Tiny (01-08-22)

  • #9
    Senior Member
    Join Date
    Apr 2012
    Posts
    726
    Thanks
    533
    Thanked 41 Times in 29 Posts
    Rep Power
    168
    Reputation
    810

    Default

    Surething - many thanks indeed for all your help, its very much appreciated. I've been away and only just seen your excellent reply. I will get back to sorting out my Garmin Dezl 580 shortly.

  • Bookmarks

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •